Hi Guys again in the rpt.conf file there is an include at the end of file. #includeifexists custom/rpt.conf is that the correct syntax ?? should the # be there nor not ? as my custom/rpt.conf file containing as below now is NOT being Parsed or Read ? If I add all this extra stuff into the rpt.conf file directly it works but problem is all the main .conf file can be over written by the allstar control portal thus this is why you add extra stuff into files in custom/.... any thoughts Thanks Barry G8SAU
Barry, That line at the end of the file should only be read if it exists. It is a way to include additional set-up if you want to separate set-up files instead of all in one file. You could reasonably have only those include lines in the file and describe each node in a include file (for example). However, it should read: #includeifexists custom/n29285.conf (example) If the file exists, it will be read into the system config. If not, it is ignored. ...mike/kb8jnm
Hi Guys again
in the rpt.conf file there is an include at the end of file.
#includeifexists custom/rpt.conf
is that the correct syntax ?? should the # be there nor not ? as my
custom/rpt.conf file containing as below now is NOT being Parsed or Read ? If I add all this extra stuff into the rpt.conf file directly it works but problem is all the main .conf file can be over written by the allstar control portal thus this is why you add extra stuff into files in custom/....
any thoughts Thanks
Barry G8SAU
_______________________________________________ App_rpt-users mailing list App_rpt-users@ohnosec.org http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users
To unsubscribe from this list please visit http://ohnosec.org/cgi-bin/mailman/listinfo/app_rpt-users and scroll down to the bottom of the page. Enter your email address and press the "Unsubscribe or edit options button" You do not need a password to unsubscribe, you can do it via email confirmation. If you have trouble unsubscribing, please send a message to the list detailing the problem.
I've had the occasional problem using this syntax. Not always. Never took the time to investigate. What I done here to maintain consistency across our nodes is have "common" conf files on each server. My naming convention, rpt_yorkstar.conf, iax_yorkstar.conf, and extensions_yorkstar.conf. In rpt.conf then point to stanzas within those files, i.e. functions=functions_yorkstar. Once I KNOW they are there, change that line to #include rpt_yorkstar.conf. This also allows me push out changes (notably new function definitions) via rsync. These go into /etc/asterisk along all the others. Bob Poff WB3AWJ
participants (3)
-
Barry -
Bob Poff -
mike@midnighteng.com